様々な事情があって、2.17 系で
e-SCOTT Smart light for EC-CUBE(2.13系)
https://www.ec-cube.net/products/detail.php?product_id=674

を導入することになりました。(現在は2系の新規利用はできません)

オーナーズストアからモジュールを購入済みでも、
モジュールが 2.17 に対応していると明記していないと、ダウンロードすることができないので、
data/class/SC_Initial.php ECCUBE_VERSION のバージョン情報を 2.13.5 などにさくっと書き換えて対応します。
検証したわけではありませんが 2.13 系に対応しているならおおよそ動くようです。
2.13.5 だと本来の 2.13.5 と区別が付かないので 2.13.7 がいいかなぁとは思います。

上記で無事にインストールできましたが、今度は設定画面で表題の件のエラーが出て、ハマりました。

Fatal error(E_ERROR): Uncaught  --> Smarty Compiler: Syntax error in template "file:\data\downloads\module\mdl_sln\templates\admin\sln_config.tpl"  on line 207 ~中略~ Unexpected ";", expected one of: "

どうやら style 属性の値の開始のクォーテーションが書いてないので smarty のコンパイルでエラーが出ているようでした。
下記のように書き足し訂正をしたところ、上手くいきました。(似たようなコードがファイル内に数カ所あります)
option 属性もクォーテーションが書いてないが、こちらは不要です。
むしろ書き足すと配列の展開が出来なくなって Array という文字列が出てしまうので注意!
それにハマって浪費しました…汗。

<!--{html_checkboxes_ex name="$key" options=$arrPayKbnKaisu selected=$arrForm[$key].value style=$arrErr[$key]|sfGetErrorColor;"}-->

↓↓↓

<!--{html_checkboxes_ex name="$key" options=$arrPayKbnKaisu selected=$arrForm[$key].value style="$arrErr[$key]|sfGetErrorColor;"}-->

新規の提供が終了しているとはいえ、凡ミスだと思われるので、できれば訂正してほしいところでした。